[Commotion-admin] [commotion-router] Build and test image for TP-Link WDR842ND router (#141)

radurambet notifications at github.com
Wed Nov 12 17:51:54 EST 2014


Related to HT mode I know the drawbacks , but what I wanted to mention is that in a clean environment the radio operates at full 40Mhz speed.

Below my working config file /etc/config/network
<pre><code>
config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option proto 'commotion'
        option class 'client'
        option type 'bridge'
        option bridge_empty '1'
        option ipaddr 'xx.xx.xx.x'
        option netmask '255.255.255.0'
        option _orig_ifname 'wlan0'
        option _orig_bridge 'true'
        option ifname 'eth0'

config interface 'wan'
        option ifname 'eth1'
        option proto 'commotion'
        option class 'wired'
        option meshed '0'
        option dhcp 'client'

config alias 'thisnode'
        option interface 'lan'
        option proto 'static'
        option ipaddr '169.254.xx.xx'
        option netmask '255.255.0.0'

config interface 'xxx_xxx'
        option class 'mesh'
        option proto 'commotion'
        option profile 'xxx_xxx'
</pre></code>

If you look in kernel log file you will find that eth0 is the switch. 

<pre>

[    0.850000] eth0: Atheros AG71xx at 0xba000000, irq 5
[    1.410000] eth0: Found an AR7240/AR9330 built-in switch
[    2.440000] eth1: Atheros AG71xx at 0xb9000000, irq 4
[    2.990000] ag71xx ag71xx.0: eth1: connected to PHY at ag71xx-mdio.1:04 [uid=004dd041, driver=Generic PHY]

</pre>

I hope this is useful to everyone having V1 or V1.1 tplink 842ND

---
Reply to this email directly or view it on GitHub:
https://github.com/opentechinstitute/commotion-router/issues/141#issuecomment-62810376
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.chambana.net/pipermail/commotion-admin/attachments/20141112/b1430dfb/attachment.html>


More information about the Commotion-admin mailing list